Which devices does the Vonage Video API work with?

Question

Which devices are supported when using the Vonage Video API?

Applies To

  • Vonage Video API
  • Mobile Devices
  • Desktop Computers
  • SDK

Answer

The Vonage Video API platform enables you to create a multi-platform app that runs on both computers and mobile devices (smartphones and tablets).

Desktop Computers

Your Vonage Video API app will work on desktop computers and laptops running any of the following browsers:

  • Google Chrome (latest release version)
  • Firefox (latest release version)
  • Opera (latest release version)
  • Electron (latest release version)
  • Safari (latest release version)
  • Microsoft Edge. Full support for Chromium-based versions of Edge (version 79+), and beta support for non-Chromium versions of Edge (version 17+). For more information, see the OpenTok.js Edge beta page.

While the Vonage Video API might work on other versions of these browsers, they are not officially supported.

Mobile Devices

Our mobile SDKs enable you to run your Vonage Video API app on mobile devices. The majority of recent versions of Android (4.1+) and iOS (8+) are supported.

If you are building web apps, your Vonage Video API app will also work with the following compatible browsers on Android and iOS:

  • Google Chrome for Android (latest release version)
  • Firefox for Android (latest release version)
  • Safari for iOS (latest release version)

Additional Information

For additional information about iOS SDK requirements, see our developer documentation on iOS SDKs.

For additional information about Android SDK requirements, see our developer documentation on Android SDKs.

For additional information about JavaScript SDK requirements, see our developer documentation on JavaScript SDKs.

Have more questions? Submit a request