Using the Vonage Video Internet Explorer Plugin

Objective

Using the Vonage Video API Internet Explorer Plugin.

Applies To

  • Video API Plugin
  • Internet Explorer

Procedure

Installing the Internet Explorer Plugin

Contact support if you are a paid support partner and require access to the machine-level plugin for IE.

  1. Begin with a computer that has download and install privileges, as well as access to the web app.
  2. When Vonage Video features are first accessed through the app, a prompt will appear that guides you towards the correct version of the user-level plugin.
  3. Download and install the plugin.
  4. Important! Confirm that the app is running correctly by opening the web app in Internet Explorer.
  5. Repeat step 2 and 3 for each remaining computer. If other computers cannot download files, the .msi from the original computer can be distributed and installed as well.

Uninstalling the Internet Explorer Plugin

  1. Open the Control Panel and go to Programs and Features.
  2. Find Media Plugin. It may be easier to sort by Publisher and look for TokBox, Inc.
  3. Highlight and click Uninstall.

This may need to be done computer by computer depending on how your network is administered. For this reason, it’s important to double check that the app functions correctly on your initial test machine.

Upgrade and Troubleshooting

The user-level plugin auto-updates and will not require any intervention. If you are a support partner that is using the machine level plugin, auto-update is not supported and updates must be rolled out manually.

When upgrading the plugin, uninstalling the older version is not required but can be done as an initial troubleshooting step if necessary.

Confirm the Add-on Is Enabled in Internet Explorer

  1. In Internet Explorer, go to Tools > Manage Add-ons.
  2. If not visible, select All add-ons under Show.
  3. Select the plugin.

Note that each version of the plugin matches exactly with a corresponding version of the JavaScript SDK. The webpage or app using the JavaScript SDK will specify the version to be used. When the webpage or app is updated to a new version of the JavaScript SDK, then PCs running the app must be upgraded to the new plugin version. If the roll out of the two does not occur simultaneously there will be a version mismatch and an error will be displayed on screen when the JavaScript SDK tries to run the plugin.

Additional Information

Different versions of the plugin are tied to Vonage Video JavaScript SDK release. Vonage Video JavaScript SDK v2.9 uses a different plugin than Vonage Video JavaScript SDK v2.10 and so on. Ensure that the appropriate version is used.

Have more questions? Submit a request