Desupporting TLS 1.1

Overview

As of 22 March 2021 the Vonage Video API platform requires all customers to use TLS 1.2. Connections using TLS 1.1 are not accepted. See the list of Supported TLS Cipher Suites for more information.

Some customers using .NET 4.5 and TLS 1.2 have experienced issues, potentially because TLS configuration is not being enforced. You can force TLS on by adding this configuration in your server set up: ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12;. This forces the use of TLS1.2 for the .NET SDK.

TokBox Considerations

If you’re using any of the supported versions of following client SDKs, your application will not be affected:

  • JS SDK
  • iOS SDK
  • Android SDK
  • Windows SDK

Some server SDKs may have dependencies you should be aware of:

  • .NET SDK - servers running with .NET v 4.0 need to upgrade their .NET version to the 4.5 .NET framework or a more recent version
  • Java SDK - Java 8 uses TLS v 1.2 as default
      • You must use Java 1.7.0_131-b31 or higher for TLS 1.1 support. For more details on TLS, SSL, and HTTPs for Java, please see the following blog from the Java Platform Group.
      • Use the latest OpenTok Java SDK as it uses async-http-client 2.x.x, which supports TLS 1.2.
  • PHP SDK - PHP > 5.6 has TLS v 1.2. Our PHP SDK only supports 5.6 and greater

If you use Vonage REST APIs, you should be aware of the libraries you are using.

Testing Your Application Server Environment

You can run scripts on your production environment to verify successful connections:

If your server fails to establish a connection with Vonage Video API, you will have to update your server environment as needed.

Have more questions? Submit a request